Software Quality Assurance & Testing Stack Exchange is a question and answer site for software quality control experts, automation engineers, and software testers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm relatively new to Selenium and since the update to 1.0.12, when I run my tests, each case with a selectWindow command fails. If I run these steps seperately, by clicking individually, it passes, so I know I have the right window ID, etc.

I've tried a pause, a waitForPopup, waitForPageToLoad, clickAndWait ... I'm not sure what else to try. I find it odd that this worked last week and all tests passed and now I'm finding that every window is not recognised.

Is anyone else having this problem? And also any more ideas how I can resolve this? (Annoyed that all my tests now fail!)

Thanks, Sarah

share|improve this question
do you get it working with version prior to "1.0.12" ? – Tarun Jul 8 '11 at 12:49
It updated itself yesterday or the day before, and it worked before that point. I re-run the whole regression pack today and it fails at every 'selectWindow' – Sarah Glanville Jul 8 '11 at 13:06
"updated it self" How did it update it self :-/ If you suspect a defect then I would request you to post it here with all possible details -!forum/selenium-developers – Tarun Jul 8 '11 at 18:02
I mean the latest build when I say 'updated itself'. Selenium was updated to v. 1.0.12 - and I didn't request the update so was automatic. I've had a look on the selenium site at the defects and I think this is a logged defect already - #1923 – Sarah Glanville Jul 12 '11 at 7:25

Known bug.

This build is supposed to fix this issue, but is not an official release yet so YMMV.

share|improve this answer
Thanks, stupid question - how do I download this? I get a 'do you want to save this file, or find a program online to open it' popup. – Sarah Glanville Jul 13 '11 at 7:34
Might help if I actually downloaded it in firefox...whoops. Thanks that seems to have worked! :o) – Sarah Glanville Jul 13 '11 at 7:43
heh :) (gah I need to make a long comment) – Ardesco Jul 13 '11 at 8:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.