Take the 2-minute tour ×
Software Quality Assurance & Testing Stack Exchange is a question and answer site for software quality control experts, automation engineers, and software testers. It's 100% free, no registration required.

I'm using robotframework+seleniumlibrary and I often got the following error when I launch test cases

Failed to start new browser session: Error while launching browser 

I'm connected by "ssh -X nome@server-ip" on my company server from where I launch TC, and after I got the error above, the only way to solve it, it is to disconnect and re-start a new ssh connection....

is there any other way to solve it?

I'm using firefox 16 as browser for my test case. thanks.

share|improve this question
add comment

2 Answers 2

If you can't determine why the browser won't launch, you can make your tests more robust. Make sure to clean the environment during test warmup, add some retry/wait/timeout wrappers around the section that launches the browser, and kill any processes and services that aren't relevant to the test.

In order to find out why the browser is crashing, you can look into the differences between failed and successful scenarios, but it might be more helpful to put in some debugging and logging code or look at event log data.

share|improve this answer
add comment

Here is an answer here which might help: https://groups.google.com/forum/?fromgroups=#!topic/selenium-users/nFhusJoAzV8

I know that I have had issues with firefox driver not killing the firefox process when it was finished and had to add code to kill all firefox processes as part of the cleanup of my tests.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.