Take the 2-minute tour ×
Software Quality Assurance & Testing Stack Exchange is a question and answer site for software quality control experts, automation engineers, and software testers. It's 100% free, no registration required.

I have a Selenium test suite configured to run with Django & teamcity but today I have noticed that when running my tests locally, Firefox launches without the Webdriver addon bar across the bottom of the window, which is visible on the Teamcity Build agent:

enter image description here

I'm not aware of any changes that have happened on my machine - Git reports no changes, so does anybody have any idea what might cause FF to launch without the WD addon? I'm not actually sure where this addon comes from, I've just always been happy to see it running without me worrying about it!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Did you upgrade Firefox (either manually or automatically).

Firefox attempts to validate all Addons every time it is upgraded. It might have rejected the Webdriver addon in your case.

share|improve this answer
    
I wondered if this might be the case. But it isn't in the addons as a disabled addon, and as I say, I can't remember if it is it's own addon or part of the IDE. –  marksweb Apr 16 '13 at 13:58
    
I've upgraded my Selenium Python bindings & also downloaded the latest version of selenium-server.jar and WebDriver is back in FF :) –  marksweb Apr 17 '13 at 12:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.