4

At the first step after installing Selenium IDE, I recorded a simple test case, but I can't play this, because of this error:

[error] Could not connect to Selenium Server. Have you started the Selenium Server yet?

I don't know cause of this error and I'm looking for a solution. Can you help me?

1

Have you started the Selenium Server yet?

Kidding! You're probably in "webdriver playback" mode. There are two ways to play back tests that were recorded with Selenium IDE: using Selenium IDE, or using Webdriver. If you're using Webdriver, you have a client that connects to a server (sometimes a remote server), so you have to start the server component in order to let the client (Selenium IDE) connect.

To turn off Webdriver playback, go to the Options dialog, and uncheck "Enable Webdriver playback". Then restart the browser you're running Selenium IDE in.

0

Another option is to install the standalone server, if you want to run the tests locally using a different browser than FireFox. This will let you use WebDriver playback to record tests in FireFox using the IDE, and play them back in IE, Chrome, etc.

To do this, do the following:

  1. Download "selenium-server-standalone-[version].jar from the selenium downloads page at http://selenium-release.storage.googleapis.com/index.html
  2. Optionally download the IE Driver Server from the same location as above
  3. Open a command prompt, navigate to the file location and enter the following command:

    java -jar selenium-server-standalone-[version].jar

    To run in IE, the command should be as follows:

    java -jar selenium-server-standalone-[version].jar -Dbwebdriver.ie.driver=IEDriverServer.exe

  4. Now the IDE should work to play back with WebDriver. You can see any errors in the command prompt window.

Note that to run using Internet Explorer, you will need to enter "iexplore" in the WebDriver tab in the IDE options (not "internet explorer" as is implied by the instructions label in the dialog).

0

Well I also faced that error you might have enabled the "Enable Webdriver Playback"

enter image description here

Just disable it. It will work. IDE Options is available on menubar click that then again click on Options In last tab there is the option for WebDriver

0

Unchecking the below option On Selenium IDE Window solved the issue for me.

Options--> Options--> Webdriver(tab)--> Enable WebDriver Playback(Uncheck)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.