2

I've got the following XPath expression's working in firebug, that returns the correct element(s):

$x("(//input[@class='intervalInput timeInput'])")

returns two elements.

$x("(//input[@class='intervalInput timeInput'])[1]") 
$x("(//input[@class='intervalInput timeInput'])[2]")

Each of the above return the correct element.

However; when I run the following code:

var matchedElements = this._selenium.GetXpathCount("(//input[@class='intervalInput timeInput'])");

The matched elements is 0.

I have also tried:

var matchedElements = this._selenium.GetXpathCount("xpath=(//input[@class='intervalInput timeInput'])");

Any Help will be greatly appreciated.

  • which language binding of Selenium are you using? – Tarun Jun 15 '11 at 13:39
2

Have managed to resolve by using Selenium 2.0 as apposed to 1.0, apparently some issues with using XPATH 2.0 with Selenium 1.0 but seems to be working fine with 2.0.

0

Did you try removing the parenthesis surrounding the xpath?


xpath="//input[@class='intervalInput timeInput']"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.