0

I am getting below error messages :

IE 11 gives intermittently error like Unable to find the element with CSS selector or XPath or XPath expression cannot be evaluated or does not result in a WebElement.

Point is i have set all the internet zones to same level and other set up. I got this error messages before but after disabling native events by the code below I was not facing errors.

    DesiredCapabilities caps = DesiredCapabilities.internetExplorer();
    caps.setCapability("ignoreZoomSetting", true);
    caps.setCapability("nativeEvents",false);

But I wonder IE instance starts and it does not even pass the values to user id and password n not even logged in but the errors I am getting after the sign in page.

It's working very fine for other browsers like Mozilla and Chrome. I got this type of errors in below versions of IE before too. Do let me know if you have any workaround for this.

  • Does same thing working proper in other browsers and other versions of IE? – Helping Hands Dec 22 '14 at 12:24
  • Are you using waits at all to ensure elements are visible on the page before interacting with them? Could this be a timing issue? – Sam Woods Dec 22 '14 at 17:23
  • @ Sam Woods : yes i am using implicit wait commands before each click on sign in page . Everything run fine on firefox and chrome .It was solved few days back as i tried to disable the native events and it worked out for me but again i am getting mentioned errors .I did not change any API for selenium or Eclipse IDE. everything is latest one i am using now. – Ranjan Gupta Dec 22 '14 at 17:37
1

There's an open issue on Selenium's bug tracker for this problem:

https://code.google.com/p/selenium/issues/detail?id=8302

It seems a recent Windows security update broke the IEWebDriver. The good news is that today's round of Windows patches includes a fix (though one user reports that it still does not work for headless mode).

0

If you are testing IE on Windows Sever, you need to turn off Enhanced Security Configuration. At least it helped in my case. To do that perform these steps:

  1. Open the Server Manager Tool. Find IE Enhanced Security Configuration link under Local Server or Security Information section (different location for 2008 and 2012 Server).

  2. Click Configure IE ESC (2008) or IE Enhanced Security Configuration (2012) and turn ESC off for both Administrators and Users.

  3. You can confirm ESC is disabled by opening res://iesetup.dll/SoftAdmin.htm address in IE (should be default home page). You should find this message:

    Caution: Internet Explorer Enhanced Security Configuration is not enabled
    

More details and screenshots from Windows Server 2008 in this blog post.

  • i am not using windows server whole framework resides in the laptop.Though i am using IE11 so i am supposed to check out the enhances security settings. and even its not visible in advanced tab of internet option. I checked using your given link res://iesetup.dll/SoftAdmin.htm and found its disabled. – Ranjan Gupta Dec 22 '14 at 17:13
  • In addition to above issue,I debugged for sign in webelements: – Ranjan Gupta Dec 23 '14 at 5:36
0

I could solve the above problem that i was facing so far.Actually ,i imported entire selenium stuffs i.e. all the system and application s/w to my local system as it is having strong configuration. After this has done, above problem was resolved.

Feel free to ask any questions on this if you have experienced same kind of issue before.

0

Guessing you would have solved this by now, anyways! What worked for me:

Open the IE11 browser and go to Tools > Internet Options > Security and under the Security Level for this Zone ensure its same for all zone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.