3

I'm using JMeter 2.12 in windows7, HTTP(s) Test Script Recorder (port: 8080, HTTPs Domain: blank, Type: HttpClient4)

I followed the below instruction to record https request in firefox.

  • add Recording Controller into Test Plan
  • add HTTP Proxy Server into WorkBench
  • click Start button.
  • open browser network settings
  • change proxy settings to localhost:8080
  • remove localhost and 127.0.0.1 from "No proxy for" field.

However, I kept getting javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure. The Recording Controller can do web requests recording.

Can anybody help me on this (what was wrong with my configuration)?

  • 1
    Please user port : 443 instead of 8080. Because here you are trying to get Https request. – Helping Hands Dec 30 '14 at 5:11
  • 1
    Thanks much Helping Hands. I have changed to port 443 on both Https Test Script Recorder and Firefox Network Setting. However, firefox got the same error message when open app page (change back Network Setting will be fine). javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure at sun.security.ssl.Alerts.getSSLException(Unknown Source) at sun.security.ssl.Alerts.getSSLException(Unknown Source) at sun.security.ssl.SSLSocketImpl.recvAlert(Unknown Source) at sun.security.ssl.SSLSocketImpl.readRecord(Unknown Source)... ... – Larryx Dec 30 '14 at 14:32
  • 1
    BTW, the target server is Herberos enabled. I have done Jmeter Kerberos configuration. Then in Test Plan I use HTTP Authorization Manager (replace HTTP Request Defaults). But firefox got the same error result. – Larryx Dec 30 '14 at 14:51
  • 1
    Jmeter.log: 2014/12/30 09:48:59 DEBUG - jmeter.protocol.http.sampler.HTTPHC3Impl: Created new HttpClient: @32229173 2014/12/30 09:48:59 WARN - org.apache.commons.httpclient.HttpMethodDirector: Required credentials not available for BASIC <any realm>@uxvnwg001a2057.sat.cbp.dhs.gov:11101 2014/12/30 09:48:59 WARN - org.apache.commons.httpclient.HttpMethodDirector: Preemptive authentication requested but no default credentials available – Larryx Dec 30 '14 at 15:50
  • 1
    No, only do regular https web browser (firefox) recording. – Larryx Dec 31 '14 at 16:23
1

Rather than using the internal proxy recorder of JMeter I's suggest you use Blazemeter's Chrome Extension.

Blazemeter is a Google Chrome Extension. You will have to do the following,

  1. Install the extension in Chrome.
  2. Sign up a free account on Blazemeter's site.
  3. Login into your account from the Extension.
  4. Start the recorder in the extension.
  5. Browser your website for which you want to record test script (JMX).
  6. Once you're done, stop the recorder.
  7. Download the JMX file from the extension.
  8. In JMeter open the test plan (JMX) file you downloaded.
  9. All Listeners and Threads. Edit the test plan if you want.
  10. Run the test and analyze the results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.