2

I have my test written in Sikuli.

However, for overnight run, my Jenkins machine do get locked. I want to understand if anyone has encountered and solved this issue before.

Note: If I manually RDP into my Jenkins machine and have create an active session then all Sikuli test pass.

Note: I cannot leave my Jenkins slave unlocked due to security or manually login via RDP in night.

1

When the computer locks, the main screen is showing the login buttons, the Sikuli tests cannot see the application anymore. You need to disable the locking.

Since you have to lock the physical machine I think your only option is to install a virtual machine on a physical machine. That way you can have the physical machine locked and the virtual-machine unlocked. No one can acces it this way.

As the test run in a virtual environment it will not be aware of the operating system it is running on, this means it also does not matter if its locked or not.

Have a look at the free VirtualBox.

  • Install an operating system
  • Setup as Jenkins slave
  • Disable screen savers and screen locking
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.