I'm trying to setup Eclipse on my local drive for Selenium 2.0/WebDriver but getting the following error when opening the application:

 Java was started but returned exit code=13
-jar C:\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0v20140415-2008.jar
-os win32
-ws win32
-arch x86_64
-launcher C:\eclipse.exe
-name Eclipse
-exitdata 2e60_5c
product org.eclipse.epp.package.java.product
-vm C:\ProgramData\Oracle\Java\javapath\javaw.exe

...which I thought looked like a Java issue - so I tried installing the latest version and got this half way through:

! Java update did not complete
Error code: 1603

I've tried:

  • Uninstalling & re-installing Eclipse IDE
  • Deleting & re-installing Eclipse IDE files
  • Updating Java JDK

Any suggestions would be appreciated!

Thanks, Dan

Edit: This is also preventing NetBeans from installing so it's definitely a Java issue. Just to clarify, I've tried NetBeans as well as Eclipse to find the root cause, I'm not trying to get them both working simultaneously. Getting this midway through the NetBeans installation:

  • Why you want both? eclipse and netbeans? Eclipse is enough for selenium2 programs. – Helping Hands Mar 12 '15 at 5:30
  • Hey, I made an edit but the title's probably not clear now. I tried Eclipse first but was getting an error, so tried Netbeans as well to see if I could work around it but, alas, it's definitely a Java issue. – trashpanda Mar 12 '15 at 7:28
  • Do you using latest JDK and have you set proper classpath? – Helping Hands Mar 12 '15 at 7:38
  • Okay, I got into work and opened my laptop... "Java SE Development Kit 8 Update 31 has successfully installed", which is odd because I don't remember setting it off last night! Have tried running Eclipse again and am getting 'exit code = 2' now, which sounds like progress. I found an answer on StackOverflow which said to delete the java path in Environment Variables, but that didn't work. Another suggested deleting java.exe and javaw.exe, but that didn't work either... the investigation continues! – trashpanda Mar 12 '15 at 9:30

The solution wasn't to delete the java path or to delete the java.exe and javaq.exe files - it was pretty much the opposite!

After uninstalling and re-installing JDK 8 (which took me to Update 40), I added the PATH variable and directory to environment variables, which was the same as before, so I guess there was a version incompatibility which update 40 resolved

So the steps were:

  • Search for 'Environment Variables' in your Start Menu's search function and click on 'Edit environment variables for your account'
  • Delete the existing PATH variable under the System Variables header
  • Download or update Java to the latest version and install
  • If Eclipse or NetBeans still won't open, find the directory of the javapath folder
  • Open the Environment Variables panel again
  • Create a new System Variable called PATH and set the Value to wherever your javapath folder is.

Anywho, hope this helps someone in future. It was a nightmare for me but got there in the end!

Environment Variables panel

  • Happy to hear that your issue resolved..:) – Helping Hands Mar 16 '15 at 3:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.