2

I am running my scripts on selenium webdriver and after every 2-3 test case I am getting this pop-up "Firefox stopped working". How should I handle this pop-up?enter image description here

4

I got the same issue when I use Firefox 39 with Selenium 2.45. After that I upgraded to Selenium 2.46 and the issue got resolved.

I think that the problem is the Firefox and Selenium version agreement. Note: the default setting will make the Firefox update automatically.

0

Follow the below steps to disable popup and error reporting. This will help the selenium tests to proceed further.

Steps to disable Mozilla crash popup

1.1 Turn Off Error Dialog through Group Policy Editor

  1. Open the Group Policy Editor by typing gpedit.msc into the Start search box or the Run dialog.
  2. Navigate to Computer Configuration > Administrative Templates > Windows Components > Windows Error Reporting. Double click on “Prevent display of the user interface for critical errors” in the pane on the right. enter image description here
  3. Click on the radio button Enabled and then press OK. enter image description here 1.2 Turn Off Error Dialog via Registry

  4. Open the Registry Editor by typing regedit into the Start search box or the Win+R Run dialog.

  5. Navigate to the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Windows Error Reporting

  1. Double click the DontShowUI entry on the right and change its value to 1, then close the registry editor.
    enter image description here 1.3 Disabling Windows Error Reporting

  2. Go to Control Panel > Action Center > Change Action Center settings (top left) > Problem reporting settings. enter image description here

  3. Select “Never check for solutions” and click OK. Ask before checking also works because the dialog won’t appear to ask you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.