0

I Downloaded the war file from the Jenkins site and started on custom port. "INFO: Jenkins is fully up and running" is shown after running several instructions. But when I tried it on a browser with "http://localhost:port" it is not connecting. It's throwing a message: "the webpage is not available"

My system contain java version 1.6 and the downloaded version of Jenkins is 1.5.

Please let me know how to resolve this issue.

4
  • 1
    I think Jenkins is default started on :8080 and not on :port Commented Jun 26, 2015 at 12:02
  • Can you provide some more information; are you using windows, linux or a mac. Did you start Jenkins using the command line or is it installed as a service. It would also help if you included the log file in your question.
    – GrahamA
    Commented Jun 26, 2015 at 19:43
  • Am having similar problem on mac and I have tried localhost:8080/jenkins and it returns 404 code. Can someone assist me with this issue pls
    – user31673
    Commented Mar 22, 2018 at 16:28
  • I am also facing the same issue .. I have docker in my system and also installed Jenkins through official site.It was successfully installed however, localhost is not opening in browser I am done all this on Mac. Commented Jun 12, 2019 at 14:45

6 Answers 6

3

As Niels has already mentioned try this

http://localhost:8080/jenkins

instead of

http://localhost:port

Let us know if this works

1
  • Yes it works, I am running the jenkins on windows machine
    – Bunny
    Commented Jun 30, 2015 at 5:03
1

I could see this file jenkins.err provide the clear information of error most of the time .

In My Situation , the below issue faced and it worked after resolving it .

Jenkins requires Java versions [8, 11] but you are running with Java 16 from C:\Program Files\Java\jdk-16 java.lang.UnsupportedClassVersionError: 60.0 at Main.verifyJavaVersion(Main.java:174) at Main.main(Main.java:142)

Thanks, Saty

0

Running jenkins in Docker and unable to access jenkin's landing page via http://localhost:8080?

Check the IP address that Docker configured to use for the default machine. Hence, jenkins is accessible via http://configured-ip:8080

0

You can create a new inbound rule for Port 8080 in Windows Firwall-->Advance setting. Once done, try to reload jenkins, it works

1
  • This is what worked for me: an inbound rule for java.exe on port 8080. Caveat, if you add the rule for java.exe in Programs and Services when you upgrade java the path usually changes. You need to edit Jenkins.xml as well as the Inbound rule. For me, the Inbound rule was pointing to C:\Program Files\Java\jre1.8.0_271\bin\java.exe but the upgrade of Java was in C:\Program Files\Java\jre1.8.0_311\bin so the rule broke and we couldn't connect to Jenkins. You'll need to change the path in the inbound rule to fix this. Commented Oct 20, 2021 at 22:48
0

It took me a while to figure this one out. For me, it started happening after changing my Windows password. The solution was to update the Credentials for Jenkins Service.

1- In Windows search bar, type services then enter. 2- Then scroll down to Jenkins and double-click on it. 3- In Jenkins Properties, select tab "Log On". 4- Select Check box "This account" 5- Update your username and password.

Voila! Now Jenkins web can connect to the Jenkins machine via Jenkins service.

0

For me Centos 7 firewall was blocking port 8080

firewall-cmd --permanent --add-port=8080/tcp

firewall-cmd --reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.