When using this code:

aqString["Format"]("%.2f", numb);

the returned number used "," as a decimal point before - which is correct since I'm in Norway.

Suddenly - like a few days ago - it started to return the decimal point as "." which is not the standard in Norway. I have no problem working around this, but since we haven't changed the locale settings on the machine or changed anything (that I'm aware of), this should not happen.

I've output my current locale with aqEnvironment.LanguageForNonUnicodePrograms and it's correct. I suspect this would only output the windows setting anyway.

Is there a way to change how TestComplete returns a decimal point? Could some settings in an obscure .ini file has changed?

Any input would be appreciated. I would just like to know how this happened. I'm going to change the flow anyway in order to make the nightly runs turn green, but I feel like I could learn something here.

  • Any software updates around the time it changed?
    – mutt
    Jun 28, 2018 at 4:31

1 Answer 1


It could be a change in the code or a configuration change in the application being tested, not the locale setting on the machine. To change the decimal separator, you can try adding a line of code before using aqString["Format"]:

aqConvert.SetFormatSettings(".", ",");

This sets the decimal separator to "." and the thousand separator to ",". If the issue still persists, you can check the application settings or the code that's being executed for changes that might have caused the behavior change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.