4

I am trying to integrate Test Link (version 1.9.14) with my JIRA cloud instance.

I was earlier using the JIRA (interface- SOAP) to connect with JIRA, but wasn't successful, because JIRA, has deprecated SOAP interface after version 6.

So, I tried to configure using JIRA (interface- REST)

My configuration file is :

 <issuetracker>
 <username>my_username</username>
 <password>my_password</password>
 <uribase>https://myjirainstance.atlassian.net/</uribase>
 <!-- CRITIC - WITH HTTP getIssue() DOES NOT WORK -->
 <uriapi>https://myjirainstance.atlassian.net/rest/api/latest/</uriapi>
<uriview>https://myjirainstance.atlassian.net/browse/</uriview>
<userinteraction>1</userinteraction>
<!-- 1: User will be able to manage following attributes from GUI -->  
<!-- Issue Type, Issue Priority, Affects Versions, Components -->
<!-- 0: values for attributes will be taken FROM this config XML from  GUI -->

<!-- Configure This if you want be able TO CREATE ISSUES -->
<projectkey>MYS</projectkey>
<issuetype>10004</issuetype>
</issuetracker>

After saving, I am seeing that the connection is still showing to be KO (not connected). The weird thing - I cannot see any error messages in the Events Logs.

I tried to check if my REST URI is correct, using SOAP-UI, . I used the URI

https://myjirainstance.atlassian.net/rest/api/latest/

but it returned a 404 error.

Has anyone tried this linking before? If so, what am I doing wrong in the configuration.

  • Do you mean to say that you are not able to interact with jira's rest api using soapUI tool? – Rao Jan 5 '16 at 19:21
  • myjirainstance.atlassian.net is the service provided by Attlassian or you have some local instance of JIRA? If the latter you should give name of your host instead. – dzieciou Jan 6 '16 at 10:20
  • I have replaced this with my cloud instance already. – demouser123 Jan 6 '16 at 10:47
  • @Rao - yes the SOAP UI shows error for this REST URI. – demouser123 Jan 6 '16 at 10:47
  • @log_file, did some time ago successfully get data from jira. Have you looked at jira documentation for the same? Have you included the authentication? – Rao Jan 7 '16 at 2:08
2

We've succesfully integrated TestLink 1.9.10 with Jira in the Cloud. My configuration for the issue tracker record in TestLink is:

    <!-- Template jirarestInterface -->

    <issuetracker>

    <username>USER</username>

    <password>XXXX/password>

    <uribase>https...baufest.atlassian.net/browse/PROJ</uribase>

    <!-- CRITIC - WITH HTTP getIssue() DOES NOT WORK -->

    <uriapi>https...baufest.atlassian.net/rest/api/latest/</uriapi>

    <uriview>https...baufest.atlassian.net/browse/</uriview>

    <!-- Configure This if you want be able TO CREATE ISSUES -->

    <projectkey>PROJ</projectkey>

    <issuetype>1</issuetype>

    </issuetracker>

Where:

  • USER is a valid Jira user that has permission to create bugs.

  • PROJ is the Key of the Project in Jira where bugs are going to be created.

  • Issue type is 1 because that's the issue type for the project PROJ that corresponds to bugs.

  • "..." corresponds to "://" (I replaced it because the answer wouldn't save otherwise)

Hope this helps.

Regards!

Cecilia

(Baufest)

| improve this answer | |
0

I was having the same issue. But after spending some time looking into testlink source code,I was able to connect teslink 1.9.14 with JIRA using Rest Api.

Here is what I did,

Change hoststring from "'user/search/?username='" to "'user/?username='" at line number 73 in File "/var/www/html/testlink/third_party/fayp-jira-rest/Jira.php".

As per JIRA Rest API to check whether user exist in system or not, the string should be http://Jirainstance/rest/api/latest/user/?username=JIRAUser.

Whereas Testlink is creating string as "http://Jirainstance/rest/api/latest/user/search/?username=JIRAUser. Which in result is returning a blank JSON, So testlink is returning connection as False. For me that is the cause of above problem.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.