2

I get the following Exception using appium An unknown server-side error occurred while processing the command. when i run this code
driver.Swipe(loc1.X, loc1.Y, loc1.X - 110, loc1.Y, 2000);
I use this line of code to swipe specific element to left, after done swipe to left i got this exception how i can solve it ?

This is my appium log

 > info: [debug] Pushing command to appium work queue: ["swipe",{"startX":134,"startY":646,"endX":24,"endY":646,"steps":56}]<br>
 > info: [debug] [BOOTSTRAP] [debug] Got data from client: {"cmd":"action","action":"swipe","params":{"startX":134,"startY":646,"endX":24,"endY":646,"steps":56}}<br>
 > info: [debug] [BOOTSTRAP] [debug] Got command of type ACTION<br>
 > info: [debug] [BOOTSTRAP] [debug] Got command action: swipe<br>
 > info: [debug] [BOOTSTRAP] [debug] Display bounds: [0,0][540,960]<br>
 > info: [debug] [BOOTSTRAP] [debug] Display bounds: [0,0][540,960]<br>
 > info: [debug] [BOOTSTRAP] [debug] Swiping from [x=134.0, y=646.0] to [x=24.0, y=646.0] with steps: 56<br>
 > info: [debug] [BOOTSTRAP] [debug] Returning result: {"value":"The swipe did not complete successfully","status":13}<br>
 > info: [debug] Responding to client with error: {"status":13,"value":{"message":"An unknown server-side error occurred while processing the command.","origValue":"The swipe did not complete successfully"},"sessionId":"3f8c0dc1-0b7f-4940-bd7d-8230c678008f"}`
  • Have you checked the logs? It may also be due to the element being not being detected by Appium. Please post the complete stack trace – demouser123 Feb 14 '16 at 15:55
  • @log_file check the question now – user3327073 Feb 14 '16 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.