0

TLDR

HP Run Results Viewer of UFT 12.52 shows Could not load run result. message on opening test result.

About UFT 12.52 Results viewing

UFT 12.52 has two possibility for results viewing:

1. Inside HP UFT window as a separate tab

enter image description here

2. In Run Results Viewer

enter image description here

The problem. Can only view last result

I can not open test result I want (just the last ones and only in UFT tool, not in HP Run Results Viewer)


a) When I try to open any test result in Run Results Viewer with option Results XML file (even those which were able to open in UFT Result View, see pic 1) there is an error "Could not load run result."

enter image description here


b) When I try to open any test result in Run Results Viewer with option Test name there are no Run names displayed (but they do exist):

enter image description here


c) My scripts do change results folder (this could be the reason as it mentioned in the post HP Run results viewer error - Could not load run result.)

Please review if there are functions in your test scripts (or test calls to other scripts) that touch the resultsdirectory,  there has been issues where the test cases have code lines to manipulate the results directory to delete data from them. Based on your description,  it only happens with some test instance,  not all test cases; which indicates that those test instances are from the same test case which have code or functions with code lines that touches the resultsdirectory.

I created new test in UFT 12.52 which does just simply a = 2 + 2, run it, tried to open results in HP Run Results Viewer, the result was the same Could not load run result. message (the test does not even involve objects not in Descriptive Programming neither in Object Repository style). So this is not the reason.

d) Can only open last results in HP UFT Result Viewer (internal) but as you can see there is even no specification which result you are opening (Res1, Res2,3,...??? just name of the test):

enter image description here

e) Performed clean uninstall of UFT (download link) than installed again but the result was the same. (Warning: java objects recognition was broken after the clean uninstall)

f) Removed HP Run Results Viewer (by running reinstallation of UTF, selected Change and deselected Results Viewer), run test in UFT and result is still shown in internal results viewer.

g) HP Run Results Viewer 12.52 opens run results created by QTP 11.00 just fine, still having problems with 12.52 test results

Question

How can I open any run result (not only recent) in HP UFT Result Viewer (internal) or in Run Results Viewer?

  • It can be related to the installation of the Run Result Viewer, the software has the permission to read where the result files are stored? Have you try to open the result of a Run after opening Run Result Viewer and connecting it to ALM? – Serpiton Feb 25 '16 at 10:36
  • @Serpiton, thanks! Now rolled back to QTP (need some urgent testing), as soon as I will use UFT again I can tell you my researches. – Ivan Gerasimenko Mar 2 '16 at 7:40
  • @Serpiton, your idea would be right if UFT is used with connection to ALM. I'm using it as a separate tool, test is run directly from UFT (or by vbscript) and stored in test's directory. There should not be any permission problems (QTP run results viewer opens results this way) – Ivan Gerasimenko Mar 23 '16 at 7:14
  • Out of curiosity, have you tried to save the result file in a different folder, maybe one that doesn't begin with an underscore? Have you also tried to execute the Result Viewer with administrative rights? – Serpiton Mar 23 '16 at 14:07
  • @Serpiton, tried this right now. Move ResXX file to root dir, run Viewer as administrator. Result is the same. Do you use 12.52? Is it working fine? – Ivan Gerasimenko Mar 23 '16 at 14:23
0

Solved !

The workaround for your problem is:

  1. Click on Tools/Options
  2. Unselect "View results when run session ends"
  3. Unselect "HTML Report"
  4. Select "Run Results Viewer Report"
  5. Click OK.

You can now view your reports.

0

Run results of UFT 12.52 tests could be opened in web browser, just click on the file:

run_results.html

Run results of UFT 12.52 test opened in Firefox:

enter image description here

And if you prefer to view results in Run Results Viewer there is a possibility to select in Tools --> Options...:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.