3

Currently am using selenium-java-2.53.0,can you tell me which is the most stable FF version for it.

  • what are your criteria for "stability"? You could always argue the most stable is the next version! – ECiurleo Apr 1 '16 at 13:42
  • 1
    I'm voting to close this question as off-topic because user is asking for most stable version of FireFox. Well they can get it from within FireFox itself or from Mozilla's website. This question has nothing to do with SQA. – IAmMilinPatel Apr 1 '16 at 14:52
  • 1
    @TESTasy The OP is asking for the version of Firefox most stable with Selenium-Java-2.53.0. I'm not sure that information is available "within Firefox itself" (what does that mean?) or from Mozilla's website. – user246 Apr 1 '16 at 18:25
  • Please do let me know which version of firefox I should use with selenium 2.52.0 as i am unable to launch firefox with this version of selenium – Pritee Singh Jul 28 '17 at 11:28
  • This is a question which can be answered by a trivial web search. github.com/SeleniumHQ/selenium/blob/master/java/CHANGELOG - FF 45 or earlier is the answer you are looking for. – Kate Paulk Jul 28 '17 at 11:48
7

According to The WebDriver Sampler: Your Top 10 Questions Answered article the information can be obtained from Selenium Changelog, for instance for Java client libraries:

v2.52.0

=======

Firefox:

  • Weakening platform restriction to enable 64-bit support
  • Fixing closed window handling in FF45

So my expectation is that version 2.52 and above were tested on Firefox 45 so it is fine to use Selenium 2.53 with Firefox 45.

Previous Firefox versions can be downloaded from Mozilla FTP site

1

I'm not sure about -most- stable but I'm running it with the latest version of Firefox (45.0.1) and none of my scripts have stopped working.

  • Hi Dave thanks for response, at my side the script has an unusual behaviour I usually get errors like Element not visible,Unable to find Element,Element for available and this happen in random order with any element which differs at various loops for same script. – Rajesh Rathod Apr 2 '16 at 6:47
0

My robot tests broke completely when updating firefox from 44.0.2 to 45.0.2. With selenium server 2.49.0

FF 44.0.2 still works fine.

Latest version of selenium-server 2.53.0 also does not work with my robot tests.

Although I think it's down to the Selenium2Library needing an update...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.