1

In the URL Bar missing http is a feature. But when I copy and paste a link and no http:// appears in the link then is it a bug? or something like any feature of the Google DOC.

4
  • As I use google doc , It is not giving HTTP links. It is only HTTPS. And about your question, http:// is not must if you have enter full domain name. Browser takes it automatically. Please provide your screenshot If you didn`t get it.
    – Sagar007
    Apr 13 '16 at 8:58
  • 4
    I'm voting to close this question as off-topic because how Google Docs manages and deals with URL has nothing to do with SQA in general. That is totally up to Google. Aug 22 '16 at 4:32
  • Hi amit pachaury - can you explain a little more what you are testing? Are you testing a browser itself, or testing a particular website? Is there any connection with google docs? Aug 22 '16 at 9:49
  • Hello Vince Bowdren- I am not testing anything, i am just making a Doc then in this i saw that some links copied with the http:// tag but some are simply paste. So that i asked a question. And want to know is that bug or anything else. Aug 23 '16 at 6:50
2

If your requierements say "When copying an URL from address bar there must be http:// in the link" then it's a bug.

If your requierements say "When copying an URL from address bar there must not be http:// in the link" then it's not a bug.

If your requierements say nothing about http:// in the copied link, then why do you test it?

0

Have your tried copy URL of this page from address bar?

You will see that on copying and then pasting, it will append HTTP. By default, browser takes HTTP and don't displays it.

In case, its HTTPS you can see HTTPS specifically appearing in address bar.

As of now, I can't see any site which on copying pasting is not showing HTTP/HTTPs.

Please re-check the link you are trying.

Not the answer you're looking for? Browse other questions tagged or ask your own question.