0

Working with selenium + maven project in eclipse. I am facing below warnings:

log4j:WARN No appenders could be found for logger(org.apache.http.client.protocol.RequestAddCookies).

log4j:WARN Please initialize the log4j system properly.

I have tried

  • Adding log4j.properties
  • Corrected jdk version
  • updated pom.xml file with accurate dependancy
  • Ensure that those files are physically available and link in build with correct + valid path
  • cleaned project in eclipse
  • updated all maven dependancies

Anyone has experience and face, please guide/suggest how those can be fixed?

  • Please check this out. – Rao Jul 8 '16 at 8:36
  • good to see your quick response. But I have tried those solutions already, No success yet ! – NarendraC Jul 8 '16 at 9:01
1

In Your Project, you have added log4j JAR but in your code you have not used any logs. This Warning can be ignored.

0

I have applied below solution steps -

  1. Remove Proxy

    • Ensure your computer is not using any proxies, connect to open network
  2. Open terminal and hit below commands:

    • rm -rf ~/.m2/repository/antlr
    • rm -rf ~/.m2/repository/aopalliance
    • rm -rf ~/.m2/repository/asm
  3. Remove/delete that particular dependent .JAR from library folder
  4. From terminal navigate to your project root folder and hit:
    • mvn -U clean install
  5. Crosscheck once that dependent all .JAR are visible under .m2 folder. Sometime few of them may not get automatically downloaded, so if not seen pls add those manually

Finally - I got everything working now :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.