I executed cmd adb devices from terminal but instead of getting list of connected devices, I observed below error:

List of devices attached
adb server version (32) doesn't match this client (36); killing...
* daemon started successfully *

How can I get list of connected device?


7 Answers 7


Faced this issue on Mac:

I have tried different solution, But below works for me -

  1. Uninstall "Vysor" plugin if you have installed for Chrome
  2. Under Home folder > find .Android folder and move to trash
  3. Goto, Android sdk > delete/move to trash platform-tools folder
  4. Again install/download from Android SDK Manager
  5. Open terminal -
    • adb kill-server
    • adb start-server
  6. Check adb devices, It will work and display you all connected devices.

Hope it helps !


I had the same issue. I realized that I updated all my packages in the SDK manager recently. And having a second look I saw that I had the Android SDK platform tools installed twice (24.0.1 and 23.0.3). After deinstalling the 23.0.3 version everything worked more stable again including Vysor.


If you are using Genymotion, go into Settings>> ADB, and instead of letting Genymotion use its custom adb, directly point it to android sdk on your system.

ALso besides genymotion, there are other applications that use adb that would cause this conflict problem. You will have to check your app list.

  • Surely your notes will help those user, who are using Geny. But I am not using Geny. Will you pls suggest what if I am using my actual android device and Mac OS? Jul 18, 2016 at 4:12
  • "ALso besides genymotion, there are other applications that use adb that would cause this conflict problem. You will have to check your app list" Try uninstalling applications that use adb. Try doing a fresh install of android sdk
    – HRVHackers
    Jul 18, 2016 at 15:56
  • I have not installed any single other application. And fresh install of Android sdk when everything is updated + working then must be too expansive! Still unable to resolve :( Jul 19, 2016 at 5:09

Are you using Vysor? You may have installed it as a Chrome plugin. Please uninstall it because it also uses the Android SDK

  • Followed by your steps I have added few more and Its finally started working back for me! I have accepted your Answer too Jul 21, 2016 at 10:00
  • I know you are newbie, But keep practice of using Up-arrow(Answer useful) instead of Thank you here on Stack atleast. Jul 21, 2016 at 11:45

I finally solved this issue by uninstalling HTC Sync.

The issue is caused by multiple running or older versions of adb.exe.

Open task manager and locate adb.exe, right click -> Open file location, in my case it showed C:\Program Files (x86)\HTC\HTC Sync Manager\HTC Sync\adb.exe.

  • goodone Dave! But I am using mac OS and I have cross checked that other application like htc sync not using adb :( Do you have another solution pls? Sep 12, 2016 at 5:33

I have GapDebug running pretty much 24/7 and I have found that it sometimes interferes with ADB. So I exit GapDebug, then start ADB, then restart GapDebug and all is well.


I have a slighlty different error message when starting adb on Android SDK

adb server version (32) doesn't match this client (36); killing...
error: could not install *smartsocket* listener: Address already in use
ADB server didn't ACK
* failed to start daemon *
error: cannot connect to daemon

If you somehow have SyncMate application installed on Mac OS X, SyncMate has and use their own adb to connect to Android devices using TCP/IP port 5037. Therefore, SyncMate adb causes port conflict with Android SDK adb default listen port.

Removing SyncMate application or change Android SDK adb port to other port than 5037 will solve this issue

  • Thanks Aryo - But I have not installed that application on my mac. Nov 22, 2016 at 1:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.