1

I am working in selenium web driver. I am using selenium 3.0 jar files and firefox version is 49. I am getting a error message. Can anybody tell me the solution ?

package Hello;



import org.openqa.selenium.By;
import org.openqa.selenium.WebDriver;
import org.openqa.selenium.WebElement;
import org.openqa.selenium.firefox.FirefoxDriver;


public class first {


    public static void main(String[] args)
    {

        System.setProperty("webdriver.gecko.driver","/home/naveen/geckodriver");
         WebDriver driver = new FirefoxDriver();
         driver.get("http://54.68.159.204/qmsadm");
            WebElement ele=driver.findElement(By.name("username"));
            ele.sendKeys("");
            ele=driver.findElement(By.name("password"));
            ele.sendKeys("");

            ele.submit();




            System.exit(0);
    }
}

Console : Oct 07, 2016 2:25:04 PM org.openqa.selenium.remote.ProtocolHandshake createSession INFO: Attempting bi-dialect session, assuming Postel's Law holds true on the remote end 1475830505565 Marionette INFO Listening on port 42877 1475830508698 Marionette INFO startBrowser cd9def2c-de8e-4868-83c6-696d073993b6 Oct 07, 2016 2:25:09 PM org.openqa.selenium.remote.ProtocolHandshake createSession INFO: Detected dialect: W3C

(firefox:4893): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(firefox:4893): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(firefox:4893): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(firefox:4893): GLib-GObject-WARNING **: /build/glib2.0-7IO_Yw/glib2.0-2.48.1/./gobject/gsignal.c:3486: signal name 'selection_changed' is invalid for instance '0x7f970701a650' of type 'MaiAtkType139'

(firefox:4893): GLib-GObject-WARNING **: /build/glib2.0-7IO_Yw/glib2.0-2.48.1/./gobject/gsignal.c:3486: signal name 'selection_changed' is invalid for instance '0x7f970701a880' of type 'MaiAtkType139'

  • Thankyou. Updating selenium version to latest solved the above problem. – veen Feb 26 '17 at 10:18
0

download latest version of selenium jar files and try it. I tried the same code in my system and it worked fine

  • Very strange - any idea what about the versioning might have been off? – corsiKa Oct 13 '16 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy