2

When I run my Selenium test suite under Jenkins a test fails. If I run the same test suite from the command prompt they all pass. When running from the command prompt, I am in the Jenkins worskpace. This where the Jenkins runs Selenium from. Has anyone got any ideas as to why this maybe? Thank you.

3
  • Please post your error
    – QAMember
    Nov 15 '16 at 10:55
  • You need to provide some more details. Keep this habit friend! Nov 16 '16 at 9:53
  • We have lots of ideas if you would share your: 1) HTML source code of the page being tested (get it locally is ok) 2) Application Code 3) Test code, then we can probably help you. Nov 16 '16 at 23:59
0

Solution:

When we execute automation script/tests using Jenkins -

  • Cross check whether you have provided few hard-coded location paths?

  • If you are creating reports you need to check whether you have required access permissions to read, write & execute?

  • Similarly, If you are taking screen-shots of failed tests, ensure you are having all access permission

I will surely update my answer, once more details will be provided for question.

Not the answer you're looking for? Browse other questions tagged or ask your own question.