I have created my test script using Selenium 3, C# and for the browser Firefox v49.

When I run my test using Visual Studio 14 it works properly and executes accordingly, but I want to use MS Test command-line arguments in order to run the test DLL file so that I wouldn't need to open Visual Studio to execute my test. Unfortunately when I run it off a bat file which I created for the tests, all the tests fail to execute.

My bat file script is noted below:-

`cd "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE"

mstest /testcontainer:"C:\Users\tmh\Documents\Visual Studio 2015\Projects\FocusCREAnalytics\FocusCREAnalytics\bin\Debug\FocusCREAnalytics.dll`

"FocusCREAnalytics.dll" contains my test project

Can someone tell me if they have experienced a similar situation before and how they rectified it? When I check the trx file there's an error which states that the geckodriver does not exist, but if that's the case then how come when I run the tests through visual studios it works but not off the bat file.


1 Answer 1


you do not give closing quotation marks in the second line:

mstest /testcontainer:"C:\Users\tmh\Documents\Visual Studio 2015\Projects\FocusCREAnalytics\FocusCREAnalytics\bin\Debug\FocusCREAnalytics.dll"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.