2

Hey, I got a problem with installation of Testlink.

After Launching XAMPP, I got that:

Checking if /var/testlink/logs/ directory exists Failed!  
Checking if /var/testlink/upload_area/ directory exists Failed! 

Im 100% sure that I got right path because I copied it from my windows. Now mycustom_config.inc.php` looks like that:

$g_repositoryPath = 'C:\xampp\htdocs\testlink\upload_area';                                                                
$tlCfg->log_path = 'C:\xampp\htdocs\testlink\logs';

I was trying copying the same code to config.inc.php (via reading testlink installation tutorials) - with no result. Now my config.php has a lot of numbers in it as default.

What's wrong guys? (OS: Win10) I will be grateful for your help.

1
  • Make sure "upload_area" is written with underscore, no space between words.
    – Yulia Safi
    Apr 9, 2019 at 23:24

3 Answers 3

1

Might have below problem in : config.inc.php

  1. First of all restart Apache httpd service and try again to install.

  2. Change path as per below :

    $g_repositoryPath = 'C:/xampp/htdocs/testlink/upload_area/'; 
    $tlCfg->log_path = 'C:/xampp/htdocs/testlink/logs/';
    

And restart Apache httpd service and try again.

Note : Windows copied path is not working as shown. It should be / or \\. I prefer / which is supported in all OS.

Hope above solution would resolve your this problem.

4
  • Thank you for your help @Sagar007 but it still doesn`t run. I changed copy path to / in config.inc.php and nothing
    – 000060
    Mar 23, 2017 at 10:22
  • @000060 Have you restart server?
    – Sagar007
    Mar 23, 2017 at 10:25
  • Just replace above line. DO not enter duplicate path.
    – Sagar007
    Mar 23, 2017 at 10:26
  • @Saga007 Now it works! Big thanks for you
    – 000060
    Mar 23, 2017 at 10:35
1

It took me very long to go to the root cause, the issue lies at- https daemon does not have access to file in concern due to SELinux policies. So simple chown, chmod would not help(group and user access). For 1.16 I resolved it with re-installing with sudo user, but for upgrade, an issue arises again even with sudo user.

And resolved issue by executing following commands, I hope this helps. (Note: You might have to mend attributes to run it successfully)

$chcon -t httpd_sys_content_rw_t "<path_to_testlink_folder>/gui/templates_c/"

$chcon -t httpd_sys_content_rw_t "/<path_to_testlink_folder>/upload_area/"

$chcon -t httpd_sys_content_rw_t "<path_to_testlink_folder>/logs"

$semanage fcontext -a -t httpd_sys_content_rw_t "<path_to_testlink_folder>(/.*)?"

$restorecon -R -v path_to_testlink_folder
0

For Mac OS Users try this in 1.9.19 version:

Make Sure with your folder name.

In config.inc.php file:

$tlCfg->log_path = TL_ABS_PATH . 'logs' . DIRECTORY_SEPARATOR;

$g_repositoryPath= TL_ABS_PATH . 'upload_area' . DIRECTORY_SEPARATOR;

After this if you got read write permission issue failed.

Goto testlink -> logs / upload_area -> press Command + I -> in Permission Enable Read Write to Everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.