3

Suddenly this began to happen after a windows update (Windows 10). Every time I execute an ADB command for example, ADB devices the CMD pops up a new CMD window like for 2 seconds then closes up and doesn't shows me the results of the command.

I've uninstalled other android emulators that I had. Tried to Uninstall/Reinstall SDK but with no success. Tried to kill/start server. This continues happening.

I have the SDK up to date Rev: 25.0.4 I have made a video so you can see in a better detail what's happening.

Video: https://www.dropbox.com/s/zjyylem5qkzb7mr/Example.mp4?dl=0

1

can you try to add the adb.exe to your windows path variables and see if this helps so you can run adb devices, adb shell etc from any directory on windows. From a glimpse at your video I think what may be happening is there is an adb.exe inside your current command prompt directory but one existing in the path already (environment variable) in a different directory

(C:Program Files (x86)\Android\android-sdk\platform-tools\adb.exe)

can you try to look around your windows environment variables -> Start -> Search "Environment Variables" -> Edit the system variable for Path and include your platform-tools folder. in my instance this is

C:\Users\simon\Desktop\adt-bundle-windows-x86_64-20130917\sdk\platform-tools\

Once done, can you close all command prompts, open a command prompt on your desktop and try "adb devices" again to see if this is still occuring then?

1

I have the latest win 10 update and android SDK and not hitting any issues.

can you run in cmd
ADB version to check ADB version android list target check android API version

As stated it may be an issue with your windows system variables. I find editing and updating them a pain and use a great 3rd party tool REE linked below. It shows your system variables clearly and will show any duplicate or unreachable paths. https://www.rapidee.com/en/download

add Path Var C:\Users\YOUR_USER\AppData\Local\Android\Sdk\platform-tools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.