0

Question:

I am trying to launch an iOS app using app-inspector. It's failing and I can see error

Internal Server Error on webpage baseURL.

Getting below error:

Error: connect ECONNREFUSED 127.0.0.1:8001

Any one resolved this? If anyone is also facing same issue, please add your findings in comments.

Environment:

  • iOS version : 10.2.1
  • Mac iOS Version : 10.12 [macOS Sierra]
  • Appium : 1.1.0-beta.2 or Appium1.6.5
  • Xcode : 8.3.3
  • no it is not working same error – anshu madan Nov 3 '17 at 9:29
2

I faced similar issue:

  • please open this /usr/local/lib/node_modules/app-inspector/node_modules/xctestwd/XCTestWD/XCTestWD.xcodeproj in xcode
  • under signin, please mention your developer id, and change the bundle id name also
  • then navigate to the folder and run this command:

    xcodebuild -project XCTestWD.xcodeproj -scheme XCTestWDUITests -destination 'platform=iOS,id=(your device name)' XCTESTWD_PORT=8001 clean test 
    

    It will install the xctestwd on port 8001

  • start u r App-inspector -u udid

It will work.

  • Didn't work :( xcodebuild -project XCTestWD.xcodeproj -scheme XCTestWDUITests -destination 'platform=iOS,id=(your device name)' XCTESTWD_PORT=8001 clean test – NarendraC Mar 30 '18 at 10:21
0

Finally, It started working for me!

  1. Clean & Build your 3 projects [Your actual targeted automation project + WebDriverAgent + XCTest]
  2. Verify Team ID is correct and Profiles are valid
  3. Crosscheck your Macaca installation on your machine
  4. Run app-inspector -u YOUR-DEVICE-ID Refer_link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.