1

I am running automation test on local url, after some time (happening randomly) url is strike-through for unknown reason and due to that , the site keeps on loading and test fails.

enter image description here

using these confg- chrome-60.0.3xx chromedriver-2.29 selenium webriver- 2.53.x

Do anyone has some explanation. Any help would be appreciated.

4
  • 1
    Sounds like two separate problems - the crossed out url is basically Chrome's indication of a security issue, but the site keeping loading feels like a different problem..have you tried to adjust/increase loading timeouts?
    – alecxe
    Sep 3 '17 at 14:22
  • 1
    yup with no success
    – bot13
    Sep 3 '17 at 16:41
  • 1
    Can you reproduce the same problem if you navigate to this exact url in the browser manually?
    – alecxe
    Sep 3 '17 at 16:48
  • 1
    manually it is working fine, no strikethrough
    – bot13
    Sep 4 '17 at 17:19
0

What I found was quitting the chromedriver as there was multiple processes of chromedriver running.

Killing the process is best solution I get. Use the Task scheduler to end the process of chromedriver.

1
  • It sounds like there is a different issue that is causing your chromedriver processes to remain. Unless an unexpected error occurred, the chromedriver process should be ended automatically when test execution is finished.
    – Cronax
    Sep 25 '17 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.