I am recording a test in JMeter using HTTPS Test Script Recorder with a Recording Controller and Firefox Browser. I want to record going to google and making a search. However, instead of google loading in browser I get the following:

501 Method not implemented.

Service not implemented. Probably used https instead of http. To record https requests, see HTTP(S) Test Script Recorder documentation.

Why does this appear and not the google webpage?

Workaround: Refresh page multiple times can make google appear after awhile.

2 Answers 2


The absolute majority of websites are using HTTPS protocol now and you should perform one more step in order to enable JMeter to decrypt and record HTTPS traffic.

When you launch HTTP(S) Test Script Recorder it creates a self-signed certificate - ApacheJMeterTemporaryRootCA.crt - in JMeter's "bin" folder. You need to add this certificate to your browser so JMeter could decrypt secure traffic. See HTTPS recording and certificates chapter of the HTTP(S) Test Script Recorder User Manual chapter for more details. Once you install the certificate you should be able to record normally.

Also be aware that doing load testing of public websites without explicit approval of these sites owner(s) might cause problems, i.e. you at least will be banned/black-listed, in some cases it might be even considered as a criminal offence.

So if you need some practice it is better to install some web application locally, this way you will have full control of the environment and will also be able to monitor resource usage caused by the increased load. If you don't have possibility to install anything on your machine you can use dedicated sites like:


Do be aware that not every client that wants to use the Test Script Recorder is a browser. I receive this same error from JMeter when proxying RobotFramework requests that rely on http.client library calls.
From what I can tell, this setup will not work with that library at all, ever. I've tried every possible combination of cert registrations and can only succeed in recreating every error possible for an SSL connection. I can get RequestsLibrary calls to work, but the Python requests library doesn't handle multipart/form-data "precisely" right, hence why I have to use http.client (to get 100% control over the payload).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.