enter image description here

I'm using Appium for mobile automation,as soon as i click on start, within no time the server gets ended, it displays below error :

Launching Appium server with command: C:\Program Files (x86)\Appium\node.exe lib\server\main.js --address --port 4723 --platform-name Android --platform-version 22 --automation-name Appium --log-no-color

Appium server process ended

does any one have solution?

  • After killing node.exe, are u getting same error or different one?
    – Gaurav
    Commented Dec 15, 2017 at 6:20
  • same again and again,no matter what i do. i still get the same thing.
    – Sanju Abel
    Commented Dec 15, 2017 at 7:57
  • Use session override flag when starting Appium, so that you don't need to kill the process every time. Sample command - appium -a -p 4723 --session-override
    – Gaurav
    Commented Dec 15, 2017 at 9:36

2 Answers 2


Unfortunately there are multiple reasons why the appium server may not start. So it is really hard to give just one right answer for the issue you are facing. But there are some things you could try to troubleshoot the issue.

  • OPTION 1- Are you having the same problem from the Appium GUI and also the command line? Remember they are not the same. You could do something like this to run the appium server from the command line

appium -a -p 4723 –session-override -dc “{\”noReset\”: \”false\”}”

If you are able to run your test via the command line then you can try restarting the Appium GUI or uninstall and re-installing it.

  • OPTION 2- Make sure you kill all the appium processes before trying to run the server. Do the following from the command line

ps -ax | grep appium

Once you get the process id number using the above command. You can do this

kill (process id number)

This will ensure all instances of appium are closed. Then you can start fresh

  • OPTION 3- Finally you can try uninstalling and re-installing the appium server from the command line by doing the following

npm uninstall -g appium

npm install -g appium@(version number of appium. E.g- 1.4.11)

Then do,

npm cache clean -f

Then, try restarting the appium server

Hope this helps.



i've found some steps to solve my issue(Fail to start appium server). If anyone got this issue, please do this! Downgrade your appium, since it's not katalon issue but the appium is incompatible with your katalon. Use appium as this video attached (appium v 1.22.3). 1. Go to ur appium directory for katalon (C:\Users\ASUS\AppData\Roaming\npm\node_modules\appium) 2. Delete all the appium folder 3. Re-install ur appium using this command : npm install -g [email protected] 4. Try to start ur katalon! Thanks,good luck guys

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.