I am trying to run SafariDriver to automate google pages. What I find is the driver opens the URL and loads the home page, but after that the driver is not responding and WebDriver is timing out.

Lines of code that are executing:


I am getting console output :

Jun 27, 2012 10:06:33 AM org.openqa.selenium.safari.SafariDriverServer start INFO: Server started at Jun 27, 2012 10:06:38 AM org.openqa.selenium.safari.SafariDriverWebSocketHandler onOpen INFO: Connection opened Jun 27, 2012 10:06:39 AM org.openqa.selenium.safari.SafariDriverWebSocketHandler onMessage INFO: Received message: {"status":0,"value":{"browserName":"safari","version":"","platform":"MAC","javascriptEnabled":true,"takesScreenshot":true,"cssSelectorsEnabled":true},"id":"78f7f1aa-8d4d-4d6b-8cc4-a58eb96bf3e2"} Jun 27, 2012 10:06:39 AM org.openqa.selenium.safari.SafariDriverConnection onMessage INFO: Processing message: {"status":0,"value":{"browserName":"safari","version":"","platform":"MAC","javascriptEnabled":true,"takesScreenshot":true,"cssSelectorsEnabled":true},"id":"78f7f1aa-8d4d-4d6b-8cc4-a58eb96bf3e2"} Jun 27, 2012 10:09:39 AM org.openqa.selenium.safari.SafariDriverServer stop INFO: Stopping server Jun 27, 2012 10:09:39 AM org.openqa.selenium.safari.SafariDriverWebSocketHandler onClose INFO: Connection closed

How can I get back the driver control and resume the rest of execution from line System.out.println(driver.getTitle());?

  • Rakesh - What happens if you comment out the System.out.println(driver.getTitle());? Does the rest of the code execute?
    – Dan Snell
    Jun 27, 2012 at 22:13
  • @DanSnell, No nothing executes after .get() opens the urls. Its like no response comes to webdriver after driver.get() executes. I tried giving different commands after driver.get(). Jun 28, 2012 at 4:31
  • As i opened the web inspector and checked in console. It was saying command inactive after opening url. Also I tried with different websites or urls. Jun 28, 2012 at 4:32
  • Its working now, was a mistake on my part. Jun 28, 2012 at 9:23
  • Rakesh - Great to hear you got it working. Could you post your resolution below so that if other folks run into a similar problem they might be able to use what you figured out to resolve their issue?
    – Dan Snell
    Jun 28, 2012 at 16:19

1 Answer 1


It's working now. I had problem with Selenium standalone server jars. I just created new Safari extension with latest code and used Selenium standalone server 2.24. Now it is working fine, I believe it was some version issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.