0

When I try to start my emulator I receive the following:

20:09   adb server version (32) doesn't match this client (39); killing...

20:09   could not read ok from ADB Server

20:09   * failed to start daemon

20:09   error: cannot connect to daemon

20:09   'C:\Users\10349\AppData\Local\Android\Sdk\platform-tools\adb.exe start-server' failed -- run manually if necessary

What was the problem? and how may I solve this problem?

  • What is the code you are using to open the emulator? – Bill Hileman Jun 4 '18 at 13:16
  • I open it straight from android studio, this little green icon on the top right – lijiahe Jun 4 '18 at 14:03
  • Perhaps it's referring to Appium server? If you have the desktop version, launch it manually, then try to launch your emulator. – Bill Hileman Jun 4 '18 at 14:06
  • I have try to follow the path to open it manually, but its being terminated once I launch it – lijiahe Jun 4 '18 at 14:30
  • Did you install it using NodeJS? npm install -g appium – Bill Hileman Jun 4 '18 at 14:43
0

You need to update your android SDK installed within android studio to match the client device version.

https://developer.android.com/studio/intro/update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.