0

I am trying to create an automation tool to test a salesforce platform. When I try to create a new form, the text is displayed but it's really just an injection from Javascript. Is there any way to have the text not disappear? Here is what my IDE looks like so far

Current script, inputs text but is not saved. In reality, text is still an empty field.

0

These are not JavaScripts. These are the locators of the particular element.

The 1st column is the action which is going to be performed. 2nd column is the locator to specify where it has to be done. 3rd column denotes the locators label. Generally when you record a script using IDE this is how it stores the value.

  • I agree with everything you've said, but to insert the text into the fields under Value, those are strings injected by javascript into the field. Is that correct? My problem is, those values for type are not saved when submitting the form. – Imran Chowdhry Jun 20 '18 at 17:59
  • There is a similar type of question which was asked previously. Please refer the below link for references. sqa.stackexchange.com/questions/7871/… – Prasanna venkatesh Jun 20 '18 at 18:12
  • While this is definitely helpful for running scripts, it still does not solve my issue of the fields disappearing. I am trying to get the text to trigger the aria-required – Imran Chowdhry Jun 20 '18 at 18:25
0

This issue will occurs due to the following reasons.

  1. Verify your firefox browser version and if it is the latest one then downgrade the browser version since selenium IDE has ended their support with firefox browser. From the version 55 selenium IDE will not support firefox. For references click here. (https://www.google.co.in/amp/s/seleniumhq.wordpress.com/2017/08/09/firefox-55-and-selenium-ide/amp/)

  2. Selenium IDE has some probelms with 'typekeys' and this will not work.

  3. Verify your page is generating dynamic Id's everytime when the page gets loaded. If random id gets generated then use different locators to send the text values.

  4. In some cases, you may need to use simple"type" command to see the value of the field. Sometimes you need to use "typeKeys'.

Workaround:

Upgrade to Selenium Webdriver instead using IDE.

Please click here for more references.

https://github.com/seleniumhq/selenium-google-code-issue-archive/issues/2898

  • The answer is, Lightning has issues that prevent selenium from automation. If it were salesforce classic, it would not have an issue. – Imran Chowdhry Jun 22 '18 at 15:11
  • "Lightning has issues that prevent selenium from automation." => If so, then use the Kantu Selenium IDE, which has XClick and XType Sendkeys - these commands simulate native OS click and keyboard events – Fabrice Zaks Nov 14 '18 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.