3

I have my WebDriver tests running parallel in IE, Chrome and firefox. When I run test in IE browser it node gets registered with the hub, and the browser opens and it gets redirected to some random localhost and it gives the message:

This is the initial start page for the WebDriver server.

I'm running my script on Secured Browser, I tried with all the way's:

setCapability(InternetExplorerDriver.IE_ENSURE_CLEAN_SESSION, true);
setCapability(CapabilityType.ACCEPT_SSL_CERTS, true);
setCapability(InternetExplorerDriver.IGNORE_ZOOM_SETTING, true);
setCapability(InternetExplorerDriver.NATIVE_EVENTS, false);
setCapability(InternetExplorerDriver.INITIAL_BROWSER_URL, "");

But still I am getting this is in the initial start page of browser error it was not Executing or Failing.

All zoom setting in IE was 100%
protected mode was on.

please help me what could be the problem and possible work around.

platform:Windows XP, IE8 browser

The same is running well in Firefox and Chrome.

  • Doing a Google reveals several possible options - have you tried doing a search and looking at the replies ? Do any of them apply to your situation ? – Phil Kirkham Jul 20 '12 at 14:29
  • 1
    What do you mean by "random localhost"? – Željko Filipin Jul 21 '12 at 12:14
  • 2
    I believe this is normal, is this somehow impeding your testing? – MichaelF Nov 5 '12 at 13:26
3

This is as designed, so there is nothing to worry about. You can then start opening your website using driver.Navigate().GoToURL() method.

1

In IE, this will usually show as the default page at the start of a test, until you provide it with a valid URL to navigate to.

Especially if you attempt to do something to the present (empty) page, it may cause an exception or problem - for example, trying to maximise the window with javascript causing this issue.

The first thing your test should do is navigate to a valid page, and then things should work smoothly at that point.

0

The same issue occurs when you didn't configure IE properly according to manual: InternetExplorer configuration Make sure:

  1. Zoom is set to 100%
  2. Protected Mode settings for each zone have the same value
0

Try this code,

 DesiredCapabilities caps = DesiredCapabilities.internetExplorer();
 caps.setCapability(InternetExplorerDriver.INITIAL_BROWSER_URL, "");
 WebDriver driver = new InternetExplorerDriver(caps);

protected by Bharat Mane Jul 19 '18 at 11:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.