1

I lately updated to the JMeter 5.0, and initially, it worked fine. But after some time, say after a day, it does not open when I try launching it. I tried launching it by clicking the jar file of JMeter, through the batch file and also by trying to run it in administrator mode, but each time it gives a different error.

When I try to open the jar file from the cmd prompt it gives following message. enter image description here

When I try to open using the batch file, I get the following error. enter image description here

If I delete the current JMeter and redownload it, it starts working fine, but after some time, it again gives the same problem.

Does anybody has any solutions??

  • I think some of the Jmeter files are corrupted try re-downloading Jmeter and let me know if you're having the same issue. – Azib Khan Dec 24 '19 at 9:15
1
  • Error 1: check JMeter log file as the error you're getting doesn't tell the full story. The file is called jmeter.log and normally lives in "bin" folder of your JMeter installation (or generated where you launch JMeter from). If it doesn't contain anything meaningful you can try increasing JMeter log verbosity for the certain components or the whole JMeter package by adding the next line to jmeter.log file

    <Logger name="org.apache.jmeter" level="debug" />
    

    This line will generate really lot information and will cause massive disk IO so JMeter will work slowly, once you figure out the problem - remove or comment this line.

  • Error 2: your PATH environment variable is not set up properly. findstr is the utility which is located under C:\Windows\System32 and for some reason it is not in your operating system PATH. You can work it around as:

    set PATH=C:\Windows\System32;%PATH%
    

    once done you can start JMeter in the same terminal window as

    jmeter.bat
    
| improve this answer | |
  • I did set the path as you told, but the error still persisted in JMeter 5.0. I downloaded the previous version of JMeter i.e. 4.0 and it is working perfectly. Must be some bug in JMeter 5.0 – Rishikesh Nov 13 '18 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.