3

I have installed Robot Framework, as well as wxPython 2.8.12.1. After I installed RIDE, and launch RIDE by executing ride.py, I am getting the following error:

C:\Python27\Scripts>ride.py
Traceback (most recent call last):
  File "C:\Python27\lib\site-packages\robotide\__init__.py", line 83, in main
    _run(inpath, not noupdatecheck, debug_console)
  File "C:\Python27\lib\site-packages\robotide\__init__.py", line 102, in _run
    from robotide.application import RIDE
  File "C:\Python27\lib\site-packages\robotide\application\__init__.py", line 16, in <module>
    from .application import RIDE, Project
  File "C:\Python27\lib\site-packages\robotide\application\application.py", line 22, in <module>
    from robotide.namespace import Namespace
  File "C:\Python27\lib\site-packages\robotide\namespace\__init__.py", line 16, in <module>
    from .namespace import Namespace
  File "C:\Python27\lib\site-packages\robotide\namespace\namespace.py", line 31, in <module>
    from robotide.publish import PUBLISHER, RideSettingsChanged, RideLogMessage
  File "C:\Python27\lib\site-packages\robotide\publish\__init__.py", line 123, in <module>
    from .messages import *
  File "C:\Python27\lib\site-packages\robotide\publish\messages.py", line 21, in <module>
    from .messages2 import *
  File "C:\Python27\lib\site-packages\robotide\publish\messages2.py", line 24, in <module>
    from robotide.publish import publisher
  File "C:\Python27\lib\site-packages\robotide\publish\publisher.py", line 24, in <module>
    from pubsub import pub
  File "C:\Python27\lib\site-packages\pubsub\pub.py", line 146
    def getDefaultPublisher() -> Publisher:
                              ^
SyntaxError: invalid syntax

These are the versions I am using:

Pillow==5.4.1
Pygments==2.3.1
Pypubsub==4.0.0
pywin32==224
robotframework==3.1.1
robotframework-ride==1.7.3.1
robotframeworklexer==1.1
six==1.12.0
typing==3.6.6
wxPython==4.0.4

Also, I installed wxPython 2.8.12.1, yet I am getting the wxPython version as 4.0.4 as mentioned above.

I am not getting the problem. Does anybody have any solutions?

2

As per this SO post the latest version of Pypupsub that is compatible with Python 2.X is 3.3.0. You have Pypubsub==4.0.0. Try to downgrade pypubsub version.

  • Thanks. I downgraded pypubsub to 3.3.0 and it solved the problem. – Rishikesh Feb 5 '19 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.