0

enter image description here

Can anyone please suggust me to solve this issue?

3
  • No i did it properly but still it showing error Mar 14, 2019 at 13:09
  • Check your Java Installation and version.
    – Faiz
    Mar 14, 2019 at 14:23
  • I installed JDK 11.0.2 Mar 18, 2019 at 9:27

2 Answers 2

0

Looks like you're trying to start the file from the archive. Unpack the archive and start from the unpacked folder.

3
  • Ofter unpacking it showing error like this Mar 14, 2019 at 11:35
  • Don't use GUI mode for load testing !, only for Test creation and Test debugging. For load testing, use CLI Mode (was NON GUI): jmeter -n -t [jmx file] -l [results file] -e -o [Path to web report folder] & increase Java Heap to meet your test requirements: Modify current env variable HEAP="-Xms1g -Xmx1g -XX:MaxMetaspaceSize=256m" in the jmeter batch file Check : jmeter.apache.org/usermanual/best-practices.html ================================================================================ An error occurred: Could not initialize class sun.font.SunFontManager errorlevel=1 Mar 14, 2019 at 11:35
  • My guess is that you have unpacked the archive improperly.
    – Alexey R.
    Mar 14, 2019 at 11:44
0

The error your are getting:

Don't use GUI mode for load testing !, only for Test creation and Test debugging. For load testing, use CLI Mode (was NON GUI): jmeter -n -t [jmx file] -l [results file] -e -o [Path to web report folder] & increase Java Heap to meet your test requirements: Modify current env variable HEAP="-Xms1g -Xmx1g -XX:MaxMetaspaceSize=256m" in the jmeter batch file Check : jmeter.apache.org/usermanual/best-practices.html 
================================================================================     
An error occurred: Could not initialize class sun.font.SunFontManager errorlevel=1

The first part of the message is a notification. It suggests that you should use the CLI mode instead of the GUI mode for load testing. You can use the following command to run JMeter in CLI mode:

jmeter -n -t [jmx file] -l [results file] -e -o [Path to web report folder]

Make sure to replace the placeholders with the actual values of your JMX file, results file, and web report folder path.

It also suggests that there might be an issue with the Java Heap settings. You may need to increase the Java Heap to meet your test requirements. You can modify the current environment variable HEAP in the jmeter batch file to do this. You can set the HEAP variable to "-Xms1g -Xmx1g -XX:MaxMetaspaceSize=256m" to allocate 1GB of memory to JMeter. You can find more information on how to modify the HEAP variable in the JMeter documentation.

The actual error message "Could not initialize class sun.font.SunFontManager" could be due to a missing font library in your system. You can try installing the missing font library to resolve this issue. Alternatively, you can disable the font checking in JMeter by adding the following line to the jmeter.properties file:

jmeter.gui.action.font.family=Dialog

This will set the font family to Dialog and disable the font checking.

I hope these suggestions help you resolve the issue you are facing with JMeter. If you still face any issues, feel free to reach out to me for further assistance.

References:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.