0

I try to configure Jmeter on Ubuntu and I cannot open HTTPS web-page even I install certificate on Mozilla, HSTS statement appears on web page.

LOGS in jmeter

2019/07/10 15:07:12 INFO - jmeter.protocol.http.proxy.Proxy: [35494] KeyStore for SSL loaded OK and put host 'safebrowsing.googleapis.com' in map with key (safebrowsing.googleapis.com) 2019/07/10 15:07:12 WARN - jmeter.protocol.http.proxy.Proxy: [35494] Problem with SSL certificate for 'safebrowsing.googleapis.com'? Ensure browser is set to accept the JMeter proxy cert: Received fatal alert: bad_certificate 2019/07/10 15:07:12 WARN - jmeter.protocol.http.proxy.Proxy: [35498] Problem with SSL certificate for 'incoming.telemetry.mozilla.org'? Ensure browser is set to accept the JMeter proxy cert: Received fatal alert: bad_certificate

HSTS enter image description here

Certificate in mozilla enter image description here

Thanks for any help.

0

Most probably you've visited the site previously and when you try to visit it once more via JMeter's MITM proxy Firefox doesn't let you in because the certificate has changed.

The solution is to clear your browsing data, if you manage to find the information relevant to the site - try to delete only the site's information only, otherwise proceed with full removal of everything since the beginning of the time.

You can also try creating a new profile however only above hint is guaranteed to work.

Check out Recording HTTPS Traffic with JMeter's Proxy Server article for more information

0

Before start you need to make sure 2 things to check:

  • "Start" button on the JMeter Proxy page. Seems obvious, I know, but better to check.

  • Do you have any other server processes running on that machine on the port 8080? You can only have one process using port 8080. If you already have a process that uses port 8080, just change your proxy to some other port number like 9191 or something that is not in used, in both the JMeter setup and in your browser.

After this try some recording with just HTTP site Ex. http://blazedemo.com/.
see if that records. If that works, then you know that the problem is setting up HTTPS.

There are two solutions for this issue

1. Turn off HTTPS Scanning:- Every antivirus or security software allows us to turn off HTTPS scanning functionality. The option can be available by different names like

  • Do not scan encrypted connections

  • HTTPS Scanning

  • Scan SSL

2. Root CA Validity:-

For older version, JMeter generates a Root CA valid only for 7 days. In this case, you can use update version or you can edit validity for CA certificate.

  • Open JMeter/bin/jmeter.properties file in any text editor as sudo user.
  • Search for below lines

The default validity for certificates created by JMeter

proxy.cert.validity=7

  • Update certificates validity for 5000 days, change it to

The default validity for certificates created by JMeter

proxy.cert.validity=5000

Note: Before updating file details keep a few points in mind.

  • Stop JMeter

  • Change the jmeter.properties

  • Delete any existing /bin/ApacheJMeterTemporaryRootCA.crt,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.