0

I am working with 'VS 2017, Version 15.9.12', I work with a Unit-Testproject but currently when I debug a test my IDE always runs the Test in the "....\TestResults\testuser_notebook1065 2019-06-11 09_23_41\Out\chromedriver.exe" Folder. Already read this thread: How to make unit test run in bin folder

And created a .testsettings-File which looks like that:

<?xml version="1.0" encoding="UTF-8"?>
<TestSettings name="Buildserver" id="a31724c1-140a-435b-a39d-dff082acb2af" xmlns="http://microsoft.com/schemas/VisualStudio/TeamTest/2010">
  <Description>These are default test settings for a local test run.</Description>
  <Deployment>
    <DeploymentItem filename="..\..\..\Facelift\Binaries\SystemTestsFacelift\" />
  </Deployment>
  <Execution>
    <TestTypeSpecific>
      <UnitTestRunConfig testTypeId="13cdc9d9-ddb5-4fa4-a97d-d965ccfc6d4b">
        <AssemblyResolution>
            <Directory Path="D:\Builds\Facelift\Binaries\SystemTestsFacelift" includeSubDirectories="true" />
        </AssemblyResolution>
      </UnitTestRunConfig>
    </TestTypeSpecific>
    <AgentRule name="Execution Agents">
    </AgentRule>
  </Execution>
</TestSettings>

Changed in in the IDE the following settings:

"Test", "Test Settings", ".... Path to my .testsetting File" "Test", "Test Settings", "Keep Test Execution Engine Running" Want to change the running Folder to "...\Tests\SystemTestsFacelift\bin\Debug"-

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.