0

I have several tests running, using the InternetExplorer Webdriver and Java to do the logic.

All of the sudden, there is 1 test that starts failing. While investigating, I find that the webdriver can't find any details about the elements that I try interacting with. It finds the elements xpath, but no innerHTML or outerHTML, and weirdly, no page source either.

The page I'm interacting with is a popup that is launched from a popup, which is launched from the main site.

I'm using IE11 and Webdriver 3.14.

I found a historical issue where the same behaviour was caused by an update by microsoft, which I recently received as well.

I'm limited in what I can do:

  • I can't uninstall IE, or the update as I'm using a company laptop
  • I can't switch to another browser as I'm using a company laptop
  • I can't change the site, as it is supplied by an external firm

I can switch Drivers

I've tried reverting to older drivers, as that was a concurrent change that happened, but to no avail.

I've tried playing with the security settings, but again, since it is a company laptop, there is not too much that I can do.

1

Since I don't have the problem anymore, I'm going to self answer:

  • I added some waits in the process, to make sure the page is fully loaded every time.
  • I upgraded my driver from 3.14 to 3.15
  • You can also accept your own answers :) – Niels van Reijmersdal Sep 30 at 15:57
  • @NielsvanReijmersdal, I still have to wait 21h – ShadowFlame Oct 1 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.