0

I am not able to define reference for java8 cucumber. Using Intellij 2019.1.1 version

  • *.feature file is registered in File Types (Examples in feature files are recognized, but not steps)
  • Cucumber for Java plugin installed
  • Substeps IntelliJ Plugin is not installed

    <dependency>
        <groupId>io.cucumber</groupId>
        <artifactId>cucumber-java8</artifactId>
        <version>5.2.0</version>
    </dependency>
    

import io.cucumber.java8.En

Any idea how to fix it?

  • It may help you sqa.stackexchange.com/questions/40044/… – Meet Feb 11 at 12:56
  • I saw it, but didnot help. I use cucumber-java8 dep, not cucumber-java as I want ot use lambdas – Stanislav Haluska Feb 11 at 13:03
  • ok sorry, for that I will try to find out some otherway. – Meet Feb 11 at 13:04
  • Try to update the version with version 2019.2.4 – Meet Feb 11 at 13:10
  • 1
    Adjusting INtellij Idea to newest 2019.3.2. version fixed it, thanks – Stanislav Haluska Feb 11 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.