I think feature files names should describe the functionality. The Cucumber Book uses
user_logs_in.feature as a name for their first example. This gives the following domain information: The system has users and there is a login function.
If I open a folder with feature files I like it best if it gives me a general idea what the application does, e.g. what its features are. Having file names with words like Verify and Jira_Codes makes me feel you are using Cucumber as a testing tool and not a collaboration tool. It makes reading the names of the files more complex and does not really assist with understanding the domain.
I do understand the wish for traceability. I do not think one feature file maps to only one Jira-ticket or Specs-document. I started adding tags to features files to link them, for example,
@TFS-123456 work items.
As I am writing this I think I would prefer to just add the traceability to the feature free text block. You can search for it, which seems good enough.
Feature: User logs in
As a User,
I want to be able to log in to the system,
So that I can use its valuable features
Implemented in JIRA-1211, JIRA-1231
Scenario: Valid credentials