2

Issue I am facing :

I have created new AVD from Android Studio (AVD Manager) but the emulator does not have internet. I tried opening www.google.com still "No Internet Connection" displayed.

If anyone might have solved this issue? Please suggest a workaround.

My ENV :

  • OS : Windows 10 (64 bit)
  • Mobile OS : Android
  • Emulator : Android R

Note - My machine is connected to a high speed internet connection. I do remember when I tried same previously I don't need to do anything additional to use the internet on android emulator.

2 Answers 2

2

Solution to fix emulator issue:

  1. Open Control Panel
  2. Click on Network and Internet
  3. Click on Internet and Sharing Center
  4. Click on your Wi-Fi Connection name Refer : Image for clarity
  5. Click on Properties
  6. Then select Internet Protocol Version 4 and click on Properties enter image description here
  7. Click Advanced -> Click on Tab DNS -> Click on Add
  8. Write 8.8.8.8 & Click Add, It will look like enter image description here
  9. Check your emulator, you should access internet

Note - Reference link

2
  • 1
    Thanks a lot... It worked for me.
    – ILearn
    Jun 14, 2021 at 10:58
  • @ILearn - Welcome to stack overflow family. Suggestion, If something worked then just upvote on Stack overflow & Avoid commenting. All the beset! Jun 27, 2021 at 12:41
0

One quick and easiest way to solve this is to choose a device with API 29 or below, there is some issue with higher API for the internet. The DNS thing was not working for me, so I tried degrading the device API level, and chrome, etc. started working. My application, however, was able to use the internet as we could fetch the data from BackEnd on higher API but had chrome issues testing some other functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.