I’m getting the following error when trying to run a Selenium/TestNg test from Jenkins.

[ERROR] Suite file /development/apps/config/jenkins/jobs/teste-automatizado/workspace/Abc/testng.xml is not a valid file

Below are my POM and testng.xml files. Am I doing something wrong here? Any help? Thanks in advance.


    <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">



    <?xml version="1.0" encoding="ISO-8859-1"?>
    <!DOCTYPE suite SYSTEM "https://testng.org/testng-1.0.dtd">
    <suite name="Suite">
      <test name="Test">
          <class name="tests.TestCreateAssistTest"/>
  • <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE suite SYSTEM "testng.org/testng-1.0.dtd"> <suite name="FirstProject_Tstng"> <test thread-count="5" name="Test"> <classes> <class name="testng_demo.Inherit"/> <class name="testng_demo.NewTestcase"/> <class name="testng_demo.TestCase"/> </classes> </test> <!-- Test --> </suite> <!-- FirstProject_Tstng --> I'm getting an error in 2nd line <!DOCTYPE....> Can anyone help me ? – Krutika Shah Jan 19 at 12:34

Try this:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE suite SYSTEM "http://testng.org/testng-1.0.dtd">
<suite name="Suite">
  <test name= "TestCases">
<class name= "tests.CreateAssistTest"/> 
</suite> <!-- Suite -->

your testng.xml is wrong (https://testng.org/doc/documentation-main.html#testng-xml), Use a good IDE. It will show the exact error.

I tried your POM and it works fine:

enter image description here

  • Hi PDHide, thanks for your answer. I'm getting the same error with this xml you sent. I'm using eclipse ide and I'm able to launch the testng.xml successfully from there or through the comand line but from Jenkins I'm getting this error. – Tester Apr 19 '20 at 22:33
  • How are you triggering this in jenkins? – PDHide Apr 19 '20 at 23:12
  • Through Maven Plugin – Tester Apr 20 '20 at 3:03
  • @Tester which jenkins version are you using , it works fine for me. I am triggering it as mvn test in a build batch file step. My jenkisn version is 2.222.1 . I used your POM only – PDHide Apr 20 '20 at 13:03
  • I'm using version 2.204.2. How do you trigger it in a build batch file step? Thanks. – Tester Apr 20 '20 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.