0

I use a UFT project several times for performance test, and I use this AOM script to execute the test 100 iterations, to reduce the UFT load memory, the script will stop and run again UFT each 10 iterations. But in some case , UFT is in "Not Responding" status( Launched but not responding) during the test, and it fails. How can I resolve this issue?

The AOM script is:

Dim qtApp,qtTest, i 
'Create a QuickTest Professional AOM object
Set qtApp = CreateObject("QuickTest.Application")
If Not qtApp.Launched then
StartUFT()
end if

set qtTest = qtApp.Test ' Get access to the test
' Get the current value of the "it_start" environment variable. This is the iteration start index.
itstart = qtTest.Environment.Value("it_start")
' Get the current value of the "it_stop" environment variable. This is the iteration stop index.
itstop = qtTest.Environment.Value("it_stop")
For i = CInt(itstart) To CInt(itstop)

If i Mod 10 = 0 Then
CloseUFT()
End If
If Not qtApp.Launched then
StartUFT()
set qtTest = qtApp.Test
end if
qtTest.Run
Next
CloseUFT()
Set qtTest = Nothing
Set qtApp = Nothing

Function StartUFT()
    qtApp.Launch
qtApp.Visible = True
qtApp.Open "<Path>" 'name of the start up script
qtApp.Options.Run.RunMode = "Fast"
qtApp.Options.Run.ViewResults = False
 End Function

 Function CloseUFT()
qtTest.Close
qtApp.quit
 End Function

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.