0
NFO: Source paths: .
INFO: Source encoding: UTF-8, default locale: en_US
INFO: ------------------------------------------------------------------------
INFO: EXECUTION FAILURE
INFO: ------------------------------------------------------------------------
INFO: Total time: 3.659s
INFO: Final Memory: 12M/134M
INFO: ------------------------------------------------------------------------
ERROR: Error during SonarQube Scanner execution
ERROR: You must install a plugin that supports the language 'Kotlin'
ERROR: 
ERROR: Re-run SonarQube Scanner using the -X switch to enable full debug logging.
WARN: Unable to locate 'report-task.txt' in the workspace. Did the SonarScanner succedeed?
ERROR: SonarQube scanner exited with non-zero code: 1
Finished: FAILURE

I'm getting above error message when I forcefully set the sonar.language=Kotlin. But when I turn off the sonar.language=Kotlin property code will automatically scan for Kotlin and XML files.

As on the image I have already installed Kotlin plugin to my Sonar server.

There for can someone please give me a solution to resolve this error.enter image description here

3

Do you need to force the SonarQube to set the language to Kotlin??

As I remembered, the sonar.language is somewhat deprecated (correct me if I am wrong). Right now, it will automatically detect the language that you are using. That's why when you try to remove the sonar.language in your configuration and build again, it should work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.