0

I have installed Robot framework and installed wxPython and then Ride. When I launch it by executing python ride.py, it runs into an error as shown below. I believe it has something to do with the wxPython version, not sure.

There is a series of UnreprError like this

    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 0.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 3.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 4.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 5.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 6.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 7.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 19.
...
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 60.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 61.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 62.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 63.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 67.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 68.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 69.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 70.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 71.
    <class 'robotide.preferences.configobj.UnreprError'> Parse error in value at line 13.

And then the stack trace shows:

Traceback (most recent call last):
  File "c:\Python38-32\lib\site-packages\robotide\application\application.py", line 58, in OnInit
    self.frame = RideFrame(self, self._controller)
  File "c:\Python38-32\lib\site-packages\robotide\ui\mainframe.py", line 175, in __init__
    self._init_ui()
  File "c:\Python38-32\lib\site-packages\robotide\ui\mainframe.py", line 279, in _init_ui
    self.tree = Tree(self, self.actions,
  File "c:\Python38-32\lib\site-packages\robotide\ui\tree.py", line 86, in __init__
    self._images = TreeImageList()
  File "c:\Python38-32\lib\site-packages\robotide\ui\images.py", line 42, in __init__
    TestCaseController: _TreeImage(self, 'robot.png'),
  File "c:\Python38-32\lib\site-packages\robotide\ui\images.py", line 80, in __init__
    self.normal = self._get_image(image_list, normal)
  File "c:\Python38-32\lib\site-packages\robotide\ui\images.py", line 91, in _get_image
    img = wx.Image(path, wx.BITMAP_TYPE_PNG).ConvertToBitmap()
wx._core.wxAssertionError: C++ assertion "strcmp(setlocale(LC_ALL, NULL), "C") == 0" failed at ..\..\src\common\intl.cpp(1579) in wxLocale::GetInfo(): You probably called setlocale() directly instead of using wxLocale and now there is a mismatch between C/C++ and Windows locale.
Things are going to break, please only change locale by creating wxLocale objects to avoid this!
OnInit returned false, exiting...
Error in atexit._run_exitfuncs:
wx._core.wxAssertionError: C++ assertion "GetEventHandler() == this" failed at ..\..\src\common\wincmn.cpp(478) in wxWindowBase::~wxWindowBase(): any pushed event handlers must have been removed

Here is what I have installed

Windows 10 
Python 3.8.3
wxPython==4.0.7.post2
six==1.15.0
Pypubsub==4.0.3
Pillow==7.1.2
Pygments==2.6.1
pywin32==228
robotframework==3.2.1
robotframework-ride==1.7.4.2
1

That version of ride does not support Python 3.8 - you will need to install a dev version - more details are at https://github.com/robotframework/RIDE/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.