0

I am having issues with IFrame element not visible on Chrome running on headless mode while running tests through Docker Containers based of the Ubuntu OS. Exact same test code is running fine on the Windows Base. Anyone encountered such issues before with iFrames running on Linux on headless mode?

5
  • Before running test any test in any box manually test the product . WIndows OS and Linux OS are two different thing thats why we have compatibility test. Verify whether the webpage works fine in linux chrome and then debug the code in non headless mode , addd more waits , add break points etc – PDHide Sep 2 '20 at 9:02
  • Don't always doubt your test automation code doubt your software under test also – PDHide Sep 2 '20 at 9:03
  • Have tried running on the same browser version in Linux and Windows and the element is present in the page. Further running test on headless mode on Chrome on Windows Base OS works fine with same code base. Just have issues on Headless mode running through Docker Containers on Chrome. Have added additional wait times, upped the CPU and Memory for containers as well as the shared memory to no avail. – Rubesh Kunwar Sep 2 '20 at 23:17
  • did you check on non headless mode docker – PDHide Sep 3 '20 at 6:40
  • Not sure worth all the troubles to configure running the docker in gui mode. Never tried before though running docker in gui mode. May be worth spending time to debug the issue with headless mode might lead a quicker turnaround. – Rubesh Kunwar Sep 3 '20 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.