2

I am facing an issue with recording Scripts in FireFox browser through JMeter.

Configuration:

I have the Proxy setting in Firefox set to Proxy -localhost; Port -8080.

I have added the RootCA certificate to the browser.

I have set the Port number to 8080 in JMeter also.

Running Script:

TestPlan >Add >Non-Test Elements

Target Controller is set to TestPlan > HTTP(S) Test Script Recorder

Port number is set to 8080

Start - The recorder is displayed and recording starts.

Issue:

In Firefox, I have launched my application URL in my Test Server. The Page title is the Application Page Title. The URL displayed in the address bar is the URL that I have launched But the page contents are not displayed. (There is no page load symbol nor is the page loading, even when left for 1 hour, contents of the page are not displayed.)

NOTE:

  • I have tried recording scripts in BlazeMeter App and Google with the same settings mentioned above and it worked fine. I am facing this issue only with my application URL.

  • I have also tried to record through Templates - I see the same issue of contents not loading

  • I do not see any error in the JMeter log as well.

Is this issue related to Network or Proxy or Firewall? I am using a Test Server which does not have Internet Connectivity and directly launches my application URL's.

Please help me understand what the issue is and let me know if there is any work around to it.

2
  • Could you please tell me what type of site you are loading whether it is a web app or a web page? – Mohamed Sulaimaan Sheriff Dec 30 '20 at 10:55
  • It is a web application developed on Blazor Technology. – user14849417 Jan 18 at 7:22
1

I can only think of 2 possible reasons:

  1. Your Firefox doesn't "respect" the localhost proxy, the functionality was introduced a couple of years ago so if you specify a localhost as the proxy host Firefox silently ignores this so you need to type about:config into the URL bar, look for network.proxy.allow_hijacking_localhost setting and set the value to true
  2. Something is corrupt with your cache, certificate or other site data, try clearing your browser history, it should fix the intermittent issues with the recording. See Recording HTTPS Traffic with JMeter's Proxy Server article for more details

Also be informed that JMeter's RootCA certificate doesn't last forever, it's life span is limited to 7 days only so you should be first starting the HTTP(S) Test Script Recorder then importing the certificate.

1
  • Thank you! 1. I set network.proxy.allow_hijacking_localhost to true 2. I cleared the cache, removed and readded the certificate again Issue is still reproducible. – user14849417 Dec 30 '20 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.