1

I am using the JMeter for recording API logs through HTTP(S) Script Recorder and I have also installed the ApacheJMeterTemporaryRootCA certificate in the mobile and set the WiFi setting in manual setting with port and Proxy hostname but when I try to run the application showing the No internet connection error every time so is there any additional setting required for setting up the connection? (Used the desktop IP and 8080 port)

NOTE: The error is showing some of the devices not in all devices. Does it depend on the OS or WiFi version?

Thank you.

1

I think default port for the HTTP(S) Test Script Recorder is 8888

enter image description here

so if you didn't change it - point your mobile to use port 8888 and make sure that incoming traffic is allowed in your operating system firewall

Also you need to take some extra steps:

  1. For iOS you need to enable full trust for root certificates

    enter image description here

  2. For Android you need to add the next section to your network_security_config.xml file:

    <base-config cleartextTrafficPermitted="true">
        <trust-anchors>
            <certificates src="system" />
            <certificates src="user" />
        </trust-anchors> 
    </base-config>
    

    then recompile your application in debug mode and replace the .apk in the device/emulator

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.