I asked this on https://community.postman.com/t/postman-proxy-does-not-save-urls-of-some-resources/19376, but no answers this far.
I’ve turned on Postman Proxy and configured Firefox (Tools -> Options -> Network, Settings, then Manual configuration of proxy servers) to use, port 5555. I can see that it works at least to some extent, because the actual URLs of addresses entered in the Firefox address bar show up in Postman (in the collection created for this purpose). I’m not sure if Postman should gather the all children URLs (that is, the URLs that are visible in the browser after pressing F12 -> Network), though - and my question is: should it? I’m confused because some (few) URLs does show up in the collection, but other do not.

I put the screenshot showing the situation so possibly it could be easier to figure out what is my point (the URL of the loaded page: http://www.kociesprawy.pl/magazyn/czytelnia_artykuly_w_kocich_sprawach/koty_i_ludzie/kocie_blogi_-_w_krainie_pieciu_kotow/).

enter image description here

After loading the above mentioned page in Firefox, I can see that, for example, the file koty-1.jpg is downloaded. Nothing like that in the collection. I've tried to figure this out on my own using screenshots, videos and so on, but I can't unequivocally settle this.

Edit: PDHide (so perhaps others too) supposed that I confused settings of how Postman's requests should be proxied with Postman built-in proxy for capturing the requests. In fact I didn't, I've configured what he has shown on the screenshot, but with the difference that I save resources to a collection, not to the history. If you want to confirm if in your case this Postman capturing function works as in mine, then you can just do the instructions https://learning.postman.com/docs/sending-requests/capturing-request-data/capturing-http-requests/ "Step 1: Set up the proxy in Postman" but setting saving to a collection, configure Firefox to make requests to port 5555 and then just make request to http://www.kociesprawy.pl/magazyn/czytelnia_artykuly_w_kocich_sprawach/koty_i_ludzie/kocie_blogi_-_w_krainie_pieciu_kotow/ and check the collection.


I think there is an issue with postman native app :

i tried saving to collection and the request is not showing up in collection but if i use postman web it shows correctly


Goto this dash board and check the collection , i will raise a bug


Raised a bug:


  • Thanks for confirming the issue, it actually seems like there is more URLs seen in the web version of Postman and at least some of the URLs that are not visible in native Postman app are visible there. I'm not sure if it is the case with all URLs that are not visible in native Postman, though. Anyway, I hope that the Postman team will fix it as soon as possible. Feb 3 '21 at 5:03

Postman proxy and interceptor are two different thing , you have misunderstood proxy settings to postman intercept feature.


enter image description here


  1. Postman manual proxy is to ensure postman requests are send through a specific proxy address
  2. Postman interceptor is to use postman as a proxy and redirect all request from browser or system through postman

IN the above settup set system proxy as

enter image description here

Now start chrome as : (From cmd)

C:\Program Files\Google\Chrome\Application\chrome.exe" --ignore-certificate-errors --ignore-urlfetcher-cert-requests
  • "you have misunderstood proxy settings to postman intercept feature" - I think I haven't, I have configured what I called Postman Proxy on the dialog window the screenshot you posted and in the shown way (the difference being that I save requests to a collection, not to a history). Well, could you set up saving to a collection and check if making the request to the URL I gave causes requests to all of its children resources to be saved? It is (a specific example of) what I want to figure out. Jan 23 '21 at 14:14
  • @TomJohnson the easies way to do is , select proxy . and update your system proxy as localhost and port (what ever you provided ) . then start chrome as "C:\Program Files\Google\Chrome\Application\chrome.exe" --ignore-certificate-errors --ignore-urlfetcher-cert-requests
    – PDHide
    Jan 23 '21 at 14:52
  • this will ensure all requests are send through postman and certificate error is ignored as (the website has postman proxy certificate)
    – PDHide
    Jan 23 '21 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.