0

I'm trying to use the safaridriver but every time I try to enable it I get a segmentation fault. I already tried to restart my laptop but the problems stays.

admin@Bens-Air ~ % safaridriver --enable
Password:
zsh: segmentation fault  safaridriver --enable

Thankful for any help :)

2
  • Which version are you using? Have you tried running it with elevated privileges -> 'sudo -u <your user> safaridriver --enable' ?
    – Prome
    Mar 17, 2021 at 11:46
  • @Prome Yes I tried running it with sudo -u <your user> safaridriver --enable and with sudo safaridriver --enablebut it still gives me the segmentation fault
    – jan
    Mar 18, 2021 at 8:20

1 Answer 1

0

I don't really know why, but it works now.

I gave the user im trying to work on with safaridriver the rights to change files of the computer. Also I seem to have used safaridriver (after giving more rights to the user) in python(I have no clue how I actually used it - but it works). So when I decided to try it again it now worked without the error described in the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.